Ubuntu 16.10 yakkety yak: teamviewer depends on libpng12-0

As I used to do in the past, yesterday I decided to install the beta2 of Ubuntu 16.10 Yakkety Yak.

The first impact is not so lovely. The desktop is very slow compared to the 15.10 version I was using before (messed up by one year of installation of the weirdest stuff).

Anyway while setting it up back for working monday I ran accross a problem with Teamviewer:

# dpkg -i teamviewer_i386.deb 
Selezionato il pacchetto teamviewer:i386 non precedentemente selezionato.
(Lettura del database... 212866 file e directory attualmente installati.)
Preparativi per estrarre teamviewer_i386.deb...
Estrazione di teamviewer:i386 (11.0.57095)...
dpkg: problemi con le dipendenze impediscono la configurazione di teamviewer:i386:
 teamviewer:i386 dipende da libpng12-0.

Teamviewer depends on libpng12-0, which doesn’t exist anymore in yakkety (replaced by libpng16-16)! So what?

The Teamviewer Support Team suggested a very easy solution: install libpng12-0 from xenial!

So let’s try…


# cd /tmp

# wget http://se.archive.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_i386.deb

# dpkg -i libpng12-0_1.2.54-1ubuntu1_i386.deb
Selezionato il pacchetto libpng12-0:i386 non precedentemente selezionato.
(Lettura del database... 225796 file e directory attualmente installati.)
Preparativi per estrarre libpng12-0_1.2.54-1ubuntu1_i386.deb...
Estrazione di libpng12-0:i386 (1.2.54-1ubuntu1)...
Configurazione di libpng12-0:i386 (1.2.54-1ubuntu1)...
Elaborazione dei trigger per libc-bin (2.24-0ubuntu1)...
# dpkg -i teamviewer_i386.deb
Selezionato il pacchetto teamviewer:i386 non precedentemente selezionato.
(Lettura del database... 225808 file e directory attualmente installati.)
Preparativi per estrarre teamviewer_i386.deb...
Estrazione di teamviewer:i386 (11.0.57095)...
Configurazione di teamviewer:i386 (11.0.57095)...

Here it is, Teamviewer installed on Ubuntu 16.10 yakkety yak!


Some background: at first I tried a very dirty hack: unpack the deb file, change the dependency and repack it back.

cd /tmp
mkdir TV
dpkg-deb -R teamviewer_i386.deb TV
sed -i 's/libpng12-0/libpng16-16/g' TV/DEBIAN/control
dpkg-deb -b TV teamviewer_i386.deb

Package is ready with the new dep. Let’s try installing it:


# dpkg -i teamviewer_i386.deb
(Lettura del database... 213154 file e directory attualmente installati.)
Preparativi per estrarre teamviewer_i386.deb...
Estrazione di teamviewer:i386 (11.0.57095) su (11.0.57095)...
Configurazione di teamviewer:i386 (11.0.57095)...

Wow, it worked! But does it also run?

teamviewer_11_on_ubutu_16-10

It seemed so, but I didn’t notice the Connect button was missing!

Un pensiero su “Ubuntu 16.10 yakkety yak: teamviewer depends on libpng12-0

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Solve : *
5 − 1 =


Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.